Android AOSP 基础一 AOSP源码下载

原文地址:http://liuwangshu.cn/framework/aosp/2-download-aosp.html

1.  安装 Python 时报错如下,由于 Ubuntu 自带 Python 所以我没有理会

lei_wang154@leiWang:~$ sudo apt-get install python
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 libc6-dev : 破坏: libperl5.26 (< 5.26.1-3) 但是 5.26.0-4 正要被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
lei_wang154@leiWang:~$ python
Python 2.7.13+ (default, Jul 19 2017, 18:15:03) 
[GCC 6.4.0 20170704] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> 
[1]+  已停止               python

2.更换完清华的源后,要关闭终端重新打开一个,才能生效。在重新打开的终端中,需要再次配置repo到PATH。

参考:https://jingyan.baidu.com/article/3c48dd34dc82d4e10be35829.html

// 关于使用 vi 编辑 .baschrc 文件时,无法使用backspace按键与方向键。(方向键变成了 ABCD
将自带的 vim-common 更换为为新的 vim-common
apt-get remove vim-common
安装新的
apt-get install vim-common

3. 如果硬盘可用空间少于 300G, 不建议操作完成后,进行快照拍摄。

注:部分内容。

由于电脑磁盘空间不足,我删掉了之前的虚拟机重新操作了一次,记录一下遇到的问题:

lei_wang154@leiWang:~$ sudo apt-get install git # 报错
...
您希望继续执行吗? [Y/n] y
忽略:1 http://packages.deepin.com/deepin panda/main amd64 git-man all 1:2.13.3-1                                
错误:2 http://packages.deepin.com/deepin panda/main amd64 git amd64 1:2.13.3-1                                  
  404  Not Found
错误:1 http://packages.deepin.com/deepin panda/main i386 git-man all 1:2.13.3-1                                 
  404  Not Found
E: 无法下载 http://packages.deepin.com/deepin/pool/main/g/git/git-man_2.13.3-1_all.deb  404  Not Found          
E: 无法下载 http://packages.deepin.com/deepin/pool/main/g/git/git_2.13.3-1_amd64.deb  404  Not Found
E: 有几个软件包无法下载,要不运行 apt-get update 或者加上 --fix-missing 的选项再试试?
lei_wang154@leiWang:~$ sudo apt-get update
正在读取软件包列表... 完成
E: 无法获得锁 /var/lib/apt/lists/lock - open (11: 资源暂时不可用)
E: 无法对目录 /var/lib/apt/lists/ 加锁
lei_wang154@leiWang:~$ sudo rm /var/cache/apt/archives/lock
lei_wang154@leiWang:~$ sudo rm /var/lib/dpkg/lock
lei_wang154@leiWang:~$ sudo apt-get update
命中:1 http://packages.deepin.com/deepin panda InRelease
正在读取软件包列表... 完成           
lei_wang154@leiWang:~$ sudo apt-get install git # 此时可以正常操作

这个阶段可能不会有提示,不要进行其他操作。继续等待同步完成。

发表评论

zh_CNChinese
zh_CNChinese